Next: , Previous: , Up: Installing GNUnet   [Contents]


1.4 Compiling and Installing GNUnet

Note: This section is a duplication of the more in depth see The GNUnet Reference Documentation in The GNUnet Reference Documentation.

First, you need to install libgnupgerror 1.27 (or later) and libgcrypt 1.7.6 (or later):

$ export GNUPGFTP="https://www.gnupg.org/ftp/gcrypt"
$ wget $GNUPGFTP/libgpg-error/libgpg-error-1.27.tar.bz2
$ tar xf libgpg-error-1.27.tar.bz2
$ cd libgpg-error-1.27
$ ./configure
$ make
$ sudo make install
$ cd ..
$ export GNUPGFTP="https://www.gnupg.org/ftp/gcrypt"
$ wget $GNUPGFTP/libgcrypt/libgcrypt-1.7.6.tar.bz2
$ tar xf libgcrypt-1.7.6.tar.bz2
$ cd libgcrypt-1.7.6
$ ./configure
$ make
$ sudo make install
$ cd ..